
Chapter 7 - More Draw Features

5.1 Transforms

Transforms include scaling, rotating, flipping, and restoring the original size of objects.

5.1.1 Scale

To proportionally scale all selected objects, choose Scale from the Arrange menu. Set the amount
of scaling as a fraction or as a percentage where 100% represents no scaling.

The Scale Selected Objects dialog lets you choose whether or not to scale font sizes, pen widths, 
or the position and size of the selected objects. Scaling can be from the upper-left corner of the 
document, or from the center of all selected objects.

5.1.2 Orientation

The Orient submenu in the Arrange menu rotates or flips selected objects around the center of all
of those objects. Rotate Left and Rotate Right rotate the items by 90°. To free rotate objects, use 
the Free Rotation Tool as described in Section 5.1.3.

Linked Pictures and QuickTime movies cannot be rotated or flipped.

5.1.3 Free Rotation

The Free Rotation Tool, found in the Tool Palette, rotates objects in 1° increments. Drag any 
handle of any selected object in any direction. Unlike Rotate Left or Rotate Right in the Orient 
submenu, all selected objects rotate around their own centers. Also unlike the Orient submenu, 
free rotation automatically converts geometric objects into polygons.

 

hen using the Free Rotation Tool, hold down the Shift key if you wish to constrain rotation to 45°
increments. Use Show Size or the Information Bar to view angle readouts as you rotate objects.

5.1.4 Restore Normal

The Restore Normal submenu in the Arrange menu works with Text, Flow Text, Bitmaps, and 
Pictures.

•
Choose Orientation to remove any rotation or flipping.
•
Choose Orientation and Color to remove rotation and flip and restore the original colors to 
pictures.



•
Choose Orientation and 72 dpi to remove rotation and flipping and restore the original size if the 
object has been resized or scaled. This does not apply to standard Text objects.
•
Choose All to do all of the above.
•
Picture Fill Colors applies only to imported Pictures. This menu command removes the color in 
the Picture, converting it to a black and white bitmap.

5.2 Align

Alignment adjusts objects based on their bounds. The top, bottom, left, and right bounds are 
determined by an object’s coordinates.

5.2.1 Align Palette

The Align Palette, in the Tool menu, has seven buttons to perform alignment on selected objects.

The top four buttons move each selected object so that the objects are all aligned along the same 
edge. For example, when the left alignment button is clicked, all of the selected objects are 
moved so that their leftmost boundaries are aligned to the left of the selection bounds.

The next two buttons align selected objects along their centers, either horizontally or vertically.

The bottom button is the Pie or Center align button. This button centers objects both horizontally
and vertically and uses the originating center when aligning arcs and wedges. Arcs and wedges 
are really segments of an oval and you may find that you want to align to the center of the whole 
oval. The Pie or Center alignment option is useful for creating pie charts.

 



5.2.2 Align Dialog

The Align dialog, in the Arrange menu, provides a way to align selected objects and to distribute 
objects evenly or proportionally. Actions are independently set for the vertical and horizontal 
axes. To help you choose the correct alignment, a dialog preview is provided. For each axis you 
can set center alignment or alignment to either bounds.

You can also Distribute the positions of objects. You can base distribution on the centers of the 
selected objects or you can place equal amounts of space between each object by distributing 
based on the object edges.

5.2.3 Realign

Realign in the Arrange menu, applies the most recent settings in the Align dialog to all selected 
objects.

5.2.4 Snap to Grid

Snap to Grid in the Arrange menu, aligns selected objects to the current ruler grid.

The Snap to Grid command can change the object shape or size. For example, using Snap to Grid
on a polygon will snap each vertex in the polygon to the grid, as shown below:

 

he size of Flow Text, Standard Text, Groups, Bitmaps, and Picture objects is not affected by Snap
to Grid. For these objects, Snap to Grip simply moves the object so that the upper-left corner of 
the object is on a grid point.

5.3 Library Tools

The Tool Palette provides three Library tools that can be used within a single document window 
or across two windows. These tools are a Copy tool, a Replace tool, and a Grab Attributes tool.

A Library is any ShareDraw drawing document in which    objects are stored for repeated use in 



other documents. Any drawing document can be treated as a Library and any group of objects 
can be treated as a palette of graphic attributes.

5.3.1 Window Cycling

All Library tools let you cycle through background document windows without changing the 
active document window. First choose a Library tool. When you move the Library tool pointer 
over the size box in the lower right corner of a background window, the size box will turn black. 
Click in the black size box to send that window behind all other windows.

When using Library documents you will want to arrange your open windows so that you have 
ready access to them. Use the Right and Bottom items in the Window Cleanup submenu in the 
Project menu to neatly arrange windows for cycling Library documents.

5.3.2 Window Scrolling

The Library tools also let you scroll background windows without making them active. Move 
any of the Library tools over a background window’s white scroll bar area. The scroll bar 
temporarily becomes active so that you can scroll to access the clip art stored in your library.

5.3.3 Copy Tool

With the Copy tool, click and drag any object, in any document, to duplicate and position it in 
the same or any other document.

 

.3.4 Replace Tool

With the Replace tool, click on an object in any open document to replace each selected object in
the active document with that object. Any number of objects may be replaced with each click.

 

.3.5 Grab Attributes Tool

To replace the graphic attributes of selected objects with those of another object, choose the Grab
Attributes tool and click on any object that has the desired attributes    in any group, in any open 
document. Any number of objects may be modified with each click.

 

hen no objects are selected, the Grab Attributes tool will change the default settings for object 



creation. In other words, subsequent objects that you draw will have the same graphic attributes 
as those you just “grabbed.”

Holding down the Shift, the Option, or both the Shift and Option keys when using the Grab 
Attributes tool will restrict which attributes are grabbed. Press the modifier keys AFTER 
pressing the mouse button. The following table shows the results of using the Shift key and the 
Option key.

 

.4 Layers

Layers are used to organize draw objects into named groups for editing and display.

5.4.1 Layer Properties

Each layer has the following five properties:

•
Layer name– for easy reference
•
Objects– the collection of objects contained in that layer
•
Front-to-Back order– for display and selection
•
Show– whether the layer is showing or hidden
•
Key– a letter from ‘a’ to ‘z’ for Command-Option key access

Each document has only one active layer at a time. In the window title bar, the name of the active
layer appears after the document name.

All layers that are above the active layer in the Front-to-Back order are invisible. All layers 



below the active layer are visible unless they have been set in the Set Layers dialog to not show.

Layers can be thought of as being like a book with transparent pages. On the first page of the 
book– the active page– you all of the other pages because they are all transparent. When you flip 
to the second page of the book, the second page becomes active and the first page is no longer 
seen. By the time you get to the last page of the book, only that page is visible because all of the 
other pages are above it.

5.4.2 Changing Layers

The active layer can be changed in one of four ways:

•
Use the Up or Down arrows in the Tool Palette (right below the zoom level indicator) to step 
through the layers one at a time.
•
Use Command-Up arrow or Command-Down arrow on the keyboard to go up or down one layer 
at a time.
•
Use an assigned Command-Option key to go directly to a layer.
•
Choose a layer by name from the Layer submenu in the Layout menu to go directly to that layer.

 

.4.3 Set Layers Dialog

All ShareDraw documents have at least one layer. To add layers to your document, choose Set 
Layers from the Layout menu. This will open the Set Layers dialog.

•
To add layers to your document, click the New button. This will add Unnamed Layers above the 
selected layer.
•
Click in the Layer Name column to select a layer for naming and key assignment.
•
Set which layer you want to be the active layer by clicking in the ‘*’ column.
•
Change layer visibility by clicking in the Show column. Turning off layer visibility means that 
that layer will not show even when it is below the active layer.
•
To change the Front-to-Back order of the layers, drag and drop in the Layer Name column.
•
To set the active layer and simultaneously exit the dialog, double-click on a layer name.



The Multi-Layer Select checkbox in the Set Layers dialog allows objects to be selected in any 
visible layer just as if they were all in the same layer. This is the default setting for ShareDraw. If
Multi-Layer Select is turned off, only objects in the active layer can be selected.

If there are no objects in the selected layer, clicking the Delete button will delete that layer.

5.4.4 Moving Objects Between Layers

To move objects from one layer into another, do the following:

1. Select the objects you wish to move.
2. Choose Cut from the Edit menu.
3. Make the destination layer the active layer.
4. Paste the object using Paste or one of the paste options in the Same Place submenu of the Edit 
menu.

5.4.5 Working With Layers 

Arrange commands Bring To Front and Send To Back do not change an object’s layer.

When creating a new object or when pasting objects, the objects are always placed in the active 
layer.

Duplicate in the Edit menu keeps the duplicate objects in the same layer as the original object.

Objects residing in different layers cannot be grouped together. All of the objects in a group must
be on the same layer. See Section 5.4.4 for information on moving objects between layers.

5.5 Multi-Copy

Multi-Copy, in the Edit menu, duplicates selected objects while applying successive rotation and 
scaling to the duplicates.

Choosing Multi-Copy brings up the Multi-Copy Effects dialog. A preview area in the dialog 
shows sample objects with the expected results of the settings in the dialog. The sample object 
with the heavier outline shows the position of the original objects. A gray area appearing in the 
preview box represents the drawing area and indicates that values you have set will place objects 
outside of the drawing.

Open ShareDraw Help before opening the Multi-Copy dialog for the first time to help you learn 
all about all of the features of this dialog.

5.5.1 Standard Multi-Copy Buttons

The Multi-Copy dialog provides four buttons for standard Multi-Copy effects:



•
Linear arranges the duplicates along a horizontal line.
•
Clock arranges the duplicates around a circle. 
•
Radial scales the duplicates smaller and smaller keeping them all in the same position.
•
Spiral arranges the duplicates in a geometric spiral.

5.5.2 Rotation and Scale

The Rotation value is the increment applied to each successive duplication. For example, if the 
Rotation value is set to 15°, the first duplicate will be rotated 15°, the second duplicate will be 
rotated 30°, the third will be rotated 45°, and so on.

The Scaling value is the amount of scaling of the last of all of the duplicates. For example, if the 
number of copies is set to 10 and Scaling is set to 50%, then the tenth duplicate will be 50% of 
the size of the original object.

You can specify scale as a percentage or as a ratio of the original object size. For example,    you 
can enter 50 or 1/2 to get a final duplicate which is one-half the size of the original object.

When the Geometric checkbox is selected, each successive scaling value is proportional to the 
next scaling value.

5.5.3 Offsets

The Offset values determine the positional arrangement of the duplicates. The offset is specified 
separately for the horizontal and the vertical directions.

Use the Relative option to set the offset to be relative to the width or height of the object. When 
Relative, the value can be in percent or a ratio of the bounds of selected objects. For example, 
200 and 2/1 both specify an offset of twice the width or height of all selected objects.

Use Points (1/72 of an inch) when you want the offset to be a fixed amount. For example, 
suppose you want to offset a vertical line to the right by 1/2 inch. In this case you would select 
the Points option and enter 36 in the Offset Horizontal box.

When selected, the Increment checkbox adds the offset values to each successive duplication. If 
turned off, the increment is applied just once.

The Scale and Rotate checkboxes determine if the whole offset is scaled and rotated. Use these 
options in conjunction with the Scale and Rotation values described in Section 5.5.2.

5.5.4 Object Changes



The last group of values control the number of duplicate objects created and whether or not the 
scaling and rotation values are applied to the objects.

The Copies value sets the number of duplications applied to all selected objects.

If Rotate Object is checked, objects are rotated by the same amount used for rotating the position
of each object. For example, if you press the standard Clock button and select the Rotate Object 
checkbox, then each object in the clock face will be rotated.

 

he Scale Object checkbox controls whether or not objects are scaled on each successive 
duplication. The Scale Object option uses the value set in the Scaling box.

5.6 Blend

The Blend submenu in the Graphic menu is available whenever at least three objects are selected.
Colors, patterns, and pen width can be blended between the selected objects. Color blending can 
be in RGB colors or in either direction around the color wheel as described below. The Blend 
submenu also provides commands to help in the setup of blending.

Objects can be selected for blending across multiple layers. If a group object is selected, the 
changes are applied to all objects in the group.

Objects are blended based on the common attributes of the frontmost and bottommost objects in 
the selection. When blending, the first and last object are not changed.

Since common attributes are used, the usual case is to blend objects of the same type. For 
example, if the first object is a line and the last object is a rectangle, only the pen width and pen 
texture will blend. If the first object is a line and the last object is a bitmap, then no blending 
occurs since a bitmap has only fill colors and a line has no fill colors. Finally, if the first or the 
last object is a group no blending will occur.

5.6.1 Selecting Objects to Create Blends



To create blends of objects you need to set the desired graphic attributes for the frontmost and 
backmost objects. It is often difficult to tell, just by looking, which is the frontmost object and 
which is the backmost object in a selection of objects. In some cases, it may be difficult to select 
the back object without also selecting the front object and vice versa. Two commands in the 
Blend Submenu can help.

Select Front selects the frontmost object in a selection of objects, deselecting all other selected 
objects. Select Back selects the backmost object and deselects all other objects in a selection.

After you have set the desired graphic attributes for the frontmost object and the backmost 
object, select all of the objects that you wish to include in the blend and then choose one of the 
blending methods provided in the Blend submenu.

5.6.2 Methods for Color Blending

Colors can be blended by their RGB (Red, Green, Blue) components or by their HSB (Hue, 
Saturation, Brightness) components.

Blend Colors in the Blend submenu creates a smooth transition of color from the first object to 
the last object in a selection.

By blending using the HSB color system, the hue, saturation, and brightness are separately 
blended from the first to last object. Hues are blended by moving around the color wheel, or 
color picker, either clockwise or counter-clockwise. Choose Blend Clockwise HSB to blend hues
in a clockwise direction  or Blend Other HSB to blend in a counter-clockwise direction. HSB 
blending, by its nature, tends to create rainbow effects.

 

.6.3 Pattern Blends

The Blend Patterns command smoothly transitions from one pattern to another. Up to 63 
transitions can occur when the last pattern is the exact inverse of the first pattern.

Blending patterns uses a special formula that lets you easily create gray scale gradients using 
only patterns. For example, suppose you have 65 objects. The first object has a white pattern and 
the last object has a solid black pattern. By blending patterns a smooth ramp can be created.
 



.6.4 Pen Width Blends

Use the Blend Pen Width command for creating a smooth transition of pen widths.

You can also choose to blend the colors, patterns, and pen widths in one action by choosing All 
of Above from the Blend submenu.


